Copy and Pasting into the terminal

A couple issues here. I can only paste into it one time and then it won’t let me paste any more data into it… I tried clearing the clip board and re-copying then paste but it still didn’t work. It seems once I use Paste it only works once per time the Terminal app is opened… The second issue when trying to create a NFT, I pasted the large BASE64 file code and once it finally pasted it froze the terminal. I’ll keep playing around with it since I really want to make an NFT!

I’ll add one more issue with terminal.
After I open 2 terminals at the same time it says “no more terminals”. But after i close them and try to open one it still says “no more terminals”

Each UI dApp may choose to spawn ⋮⋮⋮Decentralized Processing Thread(s).

The number of threads available per a user session and or IP address are configurable by a ⋮⋮⋮Node Operator.

Should limits be exceeded, the ⋮⋮⋮VM Context would refuse to spawn additional threads.

How a particular UI dApp reacts to such an event is up to the particular UI dApp, in that case, the ⋮⋮⋮ Terminal UI dApp.

Particular Case

Kindly provide steps to reproduce the issue as at the first glance, it’s looking good, opening up two terminals without an issue.

Try opening more than 2 terminals at once. Once you get info regarding “no more terminals” try closing everything and then open terminal again. Even one shows “no more terminals”, at least in my case, tested right now.

Ok so I tried to reproduce the issue.

I had to spawn 5 terminals for limits in my case to be exceeded.

yet again, that is a node-specific issue and might depend on current network usage.

Then, I went ahead with closing all the Termin

als and trying to instantiate a single instance.

it did not right away.

I had to wait for about a minute for resources on the node to recycle.

Which is when it allowed me to spawn a fully working instance of Terminal.


Now I can confirm that the issue exists. The resources should be recycled sooner. And the technology behind allows for this to be possible. I have assigned medium priority to this and moved the ticket to Production.

A fully working fix is expected within 72 hours.

Kindly thank you for your report.

@vega4 you’ve got 24 hours.

1 Like

@Alpacalypse I would like to let you know that the issue has been resolved🙏

The issue tackled mainly the mechanics of ⋮⋮⋮Decentralized Processing Threads , the management and recycling of these in particular.

We have introduced changes to both ⋮⋮⋮Core and ⋮⋮⋮Terminal UI dApp.

Yet again, kindly thank you for your report.

1 Like

We’re investigating the issue with copy-pasting right now.

@Blindmobius Kindly do note that when using the ⋮⋮⋮UI there’s no longer need to be copy-pasting base64 encoded data into the terminal. You may simply drag and drop an image into the ⋮⋮⋮ File Manager and have it uploaded to the decentralized state-machine.

Once it’s there you may use the ⋮⋮⋮NFT-related commands to assign ownership privileges and Legal properties through commands such as SETFACL and CHOWN.

@Blindmobius The issue with copy-pasting multiple times during a single life-span of the Terminal UI dApp has been confirmed and a fix is pending. Should become Operational today.