A hiccup with remote-login mechanics

Hello everyone,

We want to keep you updated on a development that was reported to us by one of our esteemed community members, @Multifacet over Discord lat night . There seems to be a minor hiccup with our login mechanics, which currently affects the ability to spawn a personalized environment.

We want to reassure you that we take this issue seriously. In fact, we are currently investigating it in real-time on our YouTube LIVE, and you’re most welcome to join us and watch as we navigate and resolve this issue.

The good news is that this is a very specific issue and doesn’t affect the overall functionality of the GRIDNET system. That said, we understand the importance of having a personalized environment and we are working hard to restore this feature as soon as possible. Our team is confident that we will have a resolution by the end of today.

We apologize for any inconvenience this may cause and appreciate your understanding as we work to resolve this. As always, we appreciate the continued support and active feedback from our community. Please continue to report any issues you encounter. Together, we make GRIDNET better!

That’s me on discord. Can I go ahead and try the tutorials without login in? What happens when I need to

@coinsgaga first of all, kindly thank you for your report. Each and every such report helps us improve rigidness of the system.

The issue turned out to have higher impact than previously anticipated. We’ve investigated this down to improper handling of Decentralized Chat Messages within GRIDNET OS.

Oh yes, GRIDNET OS does include a decentralized anonymous messaging sub-system and some of you seem to be playing around with it on daily basis.

In any case, the issue you’ve reported is being investigated on YouTube LIVE.

If we take a close look at the code snipper below:

We may see that in some cases the messages were taken from the messages’ stack but these were not actually removed from the processing loop which in turn freezed the main processing loop of one of the major system components (the Network Manager) which had significant implications.

A hot fix ha been already introduced at a single public test-net (orion.gridnet.org) which is currently rebooting and pending validation.

No, in regards to your question whether you can continue with the rest of the tutorials.

The short answer is yes, we haven’t noticed this issue to affect the processing of code throughout the network.

Yet still, we advise to wait for an hour or two once thing settle as we will be investigating this further and dispatching an update throughout the network soon.

If you tried to commit any code, most likely the processable code bundle would be compiled by the full-node you’ve been accessing and broadcasted away to the current leader (a GPU enabled node) for processing. So the process is expected to succeed.

Do notice that the log-me-in functionality is used mostly for personalization of your command line/ UI environment. (once you log-in, the system autonomously takes you to your home directory be it through SSH or UI, the Wallet UI dApp automatically refreshes the status of your account’s balance, the ‘start-menu’ displays your login-name as present within your Identity token if registered with your State Domain, the Decentralized Messaging sub-system automatically assumes your friendly identifier for the messages you write etc.)

but with that said it is not needed to log-in to affect the system or to read data. Authentication with the mobile app would be always required whenever you are ready to commit.

The implications of log-me-in go way further, for instance if you log-in the commands you execute within the terminal would simulate your identity not the identity of the owner of the current directory - yet another convenience. But yet again - it is a convenience functionality, it allows to better ‘simulate’ the actual processing results once user decides to ‘commit’ yet again - whether user logs on or not would not affect the final processing results as that involves validation of a secure ECC signature.

It can be further explained that the log-me-in mechanism causes a dynamic Security Access Token to be generated and associated with the user’s session. The token is validated and taken account for during processing of any further instructions. All the active user-mode UI dApps are notified about it as well, they can then react accordingly.

The issue has been resolved, as seen below:

Nodes are currently rebooting. ETA is ~20 minutes.

Do expect a remuneration as we do reward for each and every such report🙏

Update: the Hot-Fix we’ve introduced yesterday for Intel GPUs no seemingly caused a problem on Nvidia GPUs. It’s being investigated, we’ll keep you updated.

Update 2:

The issue on Nvidia devices seemingly was caused by the maximum number of threads not being honored as seen below:

Core tried to execute our Ultimium Proof-of-Work over 1024 threads but only 256 simultaneous units are allowed by the device at hand.

that in turn was caused by part of the code not honoring the maximal detected number of computational threads based on the task (Ultimium) and falling back to the maximum number of processing threads allowed by the hardware instead (1024) as seen below:


Now we’ve modified the code to account for the maximum detected number of computational units at all stages.

We’re still investigation the issue with Nvidia GPUs the initial problem is resolved.


As seen above the issue with Nvidia is resolved. We’re to check-up on Intel devices in a sec.

The GPU mechanics have now been validated for Intel devices as well. As seen below:

The entire report is thus now fully concluded. All changes are now being made Operational across the network:

The entre process took place and is recorded on YouTube LIVE.

@coinsgaga vega4 has signed off, let me just tell you that the ‘official’ GPU-enabled nodes are currently rebooting. Their mining operations would resume within ~15 minutes.

You are then more than welcome to keep researching / testing.

Should you stumble upon anything feel invited to report, we would take it from there. We’re currently heading towards release of GRIDNET Core 1.2 so the more we test the better.

Never doubted the speed with which this will be resolved. Kudos @vega4.
I will continue with tutorials and keep reporting.

1 Like