Guess who's back!

Hi ya’ll! I had some life issues that needed sorting out, but now I am back to my more active bug hunting :slight_smile:
I tried to recreate my friendly ID with more sacrificed tokens with and a terminal App.
I encountered some issues and was unable to even get through “sacrifice” part:

  • interface reconnected 3 times while I was using the terminal and it obviously reset my progress
  • being fast enough was the key, I managed to get a QR code rendered in a terminal but then Gridnet Mobile App decided to do “connection failed” - after scanning now visible QR code. I tried few times and it did not work.

On an unrelated note. While I suck at coding, an App for an easy Friendly ID setup would help a lot of new and old members alike. I am willing to contribute 1000 GNC as an incentive to whoever makes that App.
2# unrelated note - damn your updates made Gridnet fast, very nice work

First of all, welcome back! We’ve missed your meticulous bug hunting skills and are excited to hear you’re back in action. Your past contributions have been invaluable to us, and we’re looking forward to any new findings that will help us further refine GRIDNET.

We deeply apologize for the inconvenience you faced with the “sacrifice” part and the interface reconnecting issues. As it happens, our official nodes were going through multiple reboots yesterday in preparation for a pending release. Today, some nodes are revalidating the entire history of events from scratch. We are aware of some connection issues, including the 443 UDP port blockage (on nodes deployed by third parties) that prevents mobile apps from connecting. Rest assured, we’ve opened an internal ticket to address these matters with the highest priority.

Thank you for your suggestion about an App for easy Friendly ID setup.

And finally, we’d like to address your query regarding the addition of assets to an already deployed Identity Token. As of now, the system does NOT allow for the addition of assets to existing Identity Tokens. We appreciate your understanding on this matter, we might be willing to reconsider this though!

On a brighter note, we’re thrilled you noticed the speed improvements in GRIDNET OS! We’ve been hard at work to make it as fast and efficient as possible, and it’s gratifying to know that it hasn’t gone unnoticed.

Cheers, and welcome back to the GRIDNET family!

Ok, I will just be replying here for all the bits and pieces I find :slight_smile:
Gridscript++ guide link on that forum does not work for me : Unveiling the Power of Cryptography in GridScript++: A Comprehensive Guide Link in that topic points to here/ and there is nothing, I have to copy link manually and then it works. Just a minor inconvenience.
Token Pools in Wallet App are not working as intended - not working for me, I cannot create any token pool.
I tried messing up with Casino App, it turns out I can’t send GNC from my Mobile App to casino account. It does not work through terminal either

Of course I just read on X/Twit that Nodes are doing some crazies again, I will recheck my points later on :wink:

@Alpacalypse Thank you for the detailed feedback! It’s community members like you that help us continuously refine and improve.

  1. Gridscript++ Guide Link: Apologies for the inconvenience. We’ve looked into it and have now fixed the link to the “Unveiling the Power of Cryptography in GridScript++: A Comprehensive Guide”. Please give it another try.

  2. Token Pools in Wallet App: We want to ensure the best experience possible, so I appreciate you pointing this out. Could you provide a step-by-step account of what you did and where you faced an issue? This will help us zero in on the problem and address it more efficiently.

  3. Casino App: It seems you’re quite the early bird! We’re excited about the Casino App as much as you are, but the tutorial regarding its functionalities is still in the pipeline. We’ll be rolling it out soon to guide you through the entire process.

In regards to the casino app in other to test it, first make sure you are in the scope of an account which you own, then you need to execute a command which reassembles the one below:

callTransfer 5 /casino/dice.gpp  -GNC

What happened? The above command would cause the amount of 5 GNC to be issued to the /casino/dice.gpp GridScript++ application. You would then either win or loose!

Interesting point to note is - you have not needed to execute the Begin Transaction command at all. All it now takes to commit the results onto the network is to Commit! (type ‘ct’ hit enter and scan the QR code once shown). The GridScript instructions which have been formulated under the hood can be seen through the View Thread (vt) command as usual.

As for the note on Nodes, we’re actively monitoring and ensuring that they’re operating optimally. Do recheck your points later, and feel free to share any other feedback or issues you come across. Your insights are invaluable to us! :blush:

Thanks for the fast response :slight_smile:
In regard of the 2nd point, I simply opened Wallet App, went to Token Pool tab, set up a Pool and tried to click “generate”. Nothing happened.
Casino App is an interesting case, as I have executed that command you provided few times (without commiting) and it appears that my access is either blocked or the network crashed (sorry).

Thank you for the detailed feedback and your patience. :blush:

Regarding the 2nd point with the Wallet App, we appreciate you highlighting this. Your description provides a clear picture of the issue, and we’ll be looking into it promptly.

As for the Casino App and the issues you’re encountering, please be informed that our official nodes are currently being rebooted and are undergoing various maintenance tasks. This might be causing the irregularities you’re experiencing. We are actively working to stabilize things and will make sure to notify you as soon as everything is settled.

Thanks for your understanding and continued support!

to say that the official nodes are stress tested today would not do justice… these are being tossed around walls all day long ;p all mechanics behind the casino dApp (and the underlying mechanics) have been already marked as Operational so I’m pretty sure the difficulties you are facing stem from the current network conditions… let’s see once nodes have settled…

@CodesInChaos please keep me updated on the status of this (casino thing).

I have patiently waited for all the commotion to finish so I can get back to messing around :slight_smile:
I have encountered an issue within File manager App - I cannot upload a file or create a file within my state domain even thou I am logged in via Mobile App. Are you updating stuff again or it is an actual issue?

recent days were rather tough on the network kindly retry and report back

Yes, it is still an issue. If I choose “upload file” and select on-chain UI says that I do not have permission.
If I try to create a new file, file manager boots me out of my catalog/state domain and UI says no permission to perform action as well.

thank you @Alpacalypse for your report!

I’ve already assigned this for validation, will keep you posted!